Conflict with Unity Ads?


(Carine Rousseau) #1

Hi Leslie,
I know you don’t develop Vinoma for mobile but in fact, it works very well for mobile. But I can’t put ads. I tried with Unity Ads, but nothing happens.
The ads are unavailable. I tried several methods, I even bought a small asset (easy Unity ads), but still nothing. If I try in a non-Vinoma project, it works, but in my Vinoma project, there’s just nothing happening (no message error in console).
Can it be that there is simply a conflict between Unity Ads and Vinoma?
Vinoma would work with another ads ?
Will I have the same problem with in-app purchases?

ads1


ads3


(Leslie Young) #2

I have no idea what the problem could be since I’ve never used the ads system before. I do not even know if the ads require a UI in place or if it just appear over everything else without developer needing to do something, If it require for example some UI or Sprite to show up in then it could be that, that just needs a higher sort order to appear before UI. - but ye… I dunno if it would work like this. My feeling is that the Unity ads at least would get rendered via some camera which renders last.


(Carine Rousseau) #3

Will the new asset in preparation be more compatible with more platforms (mobile ?) and
Supported 3-rd party plugins ?
Vinoma is great but it’s difficult when I want to use something other than Vinoma in Vinoma.

I will repeat tests for ads. It doesn’t work, I would do a lite and paying version of my game.


(Leslie Young) #4

I will continue to only officially support Windows, OSX, and Linux with the new tools. I do not have the resources or time to support too many different platforms.

Maybe try and create a clean project with only the Unity ads present (not even Vinoma install in that) to see if you can get ads to work. Once that works you might have better idea of what is required to make ads work before adding it into your Vinoma based project.


(Carine Rousseau) #5

It’s work now :slight_smile:
It was my mistake, beacause I had install Unity Ads asset and Easy Unity Ads asset at the same time.
I desinstall Unity Ads Asset and it works :slight_smile: