Crash on Quit game


(Helgard de Barros) #1

Has anything changed with the Unity or Plygame updates in relation to this? When I click the “Exit Game” button the game is crashing. This was working fine before and I haven’t changed anything on the RPGUI.

Also, I can’t seem to find the error log file anymore?


(Helgard de Barros) #2

Tried replacing that button with a Plyblox.TriggerEvent to exit the game and the same thing happens. The cursor turns into a blue rotating circle and the screen freezes. The only way to exit is to push the Windows key and click the close window option. I can’t even open the task manager.


(Helgard de Barros) #3

This was working on the last build on the 23rd before the updates.


(noah) #4

Hi,
Of course Leslie’s opinion is needed here but, have you tried some simple troubleshooting to “isolate” the problem? I mean, what I suggest is to create a new project, load it with PlyGame, load the rpg_ui and test the Exit button just like that, to see if you can reproduce the problem with the minimal elements.

I’m using Unity 2018 (the latest release downloaded over the weekend) but I didn’t update plyGame (and I haven’t updated it since the 2017 compatibility update from months ago and I just saw there’s an update on May 3rd… I still wonder how it is running without crashing), so the old version is working fine with me, including the Exit block.


(Helgard de Barros) #5

OK, I have sort of narrowed down the problem.

I opened a previous version made in 2017.3.1, which worked when I made a build, and updated that to Unity 2017.4.3f1, made a build, and now it crashes.

So it isn’t the Plygame update but the Unity update that is causing the crash.


(Leslie Young) #6

Does the game’s log file include anything useful to go by?

@Noah There was not too much that changed. Mainly some deprecated methods. Unity can actually update the DLLs when you import a project into a newer version of Unity.


(Helgard de Barros) #9

OK, I found where the log file is. Nothing useful to me. The end of it says:

"----- Total AssetImport time: 0.102604s, AssetImport time: 0.000000s, Asset hashing: 0.000000s [0 B, 0.000000 mb/s]

[Package Manager] Server::Kill – Server was shutdown
Cleanup mono"


(Helgard de Barros) #10

The Quit button on my Main menu scene is still working. This has the same block as I tried on the Exit Game button. So if all else fails, I can just remove that Exit Game button, the player will have to go to the main menu to use the Quit Game button to exit the game.