Footsteps by itsmars


(Alien) #21

sure, i should be around later to test things out. much appreciated.


(Marshall Heffernan) #22

Try the debug script, you should get a message to your console every time a sound plays.

Like I said, let me know if you get extra debugs when you stop walking.

F̶o̶o̶t̶s̶t̶e̶p̶M̶a̶s̶t̶e̶r̶_̶C̶u̶r̶v̶e̶s̶_̶d̶e̶b̶u̶g̶.̶c̶s̶ (46.4 KB)


(Alien) #23

i placed the debug scrip in, and do get the debug message (and step sounds) after stop walking.


(Marshall Heffernan) #24

I’m making the adjustments in C# now. :wink: Hope it works.


(Marshall Heffernan) #25

Try this one?

FootstepMaster_Curves.cs (23.3 KB)


(Alien) #26

@itsmars works great! fixed the issue.

thanks so much. i owe you a beer or beverage of your choice!


(DarkDeivel) #27

I use Legacy Animation, there is no decision on the Footsteps for this animation system?


(Marshall Heffernan) #28

It wasn’t meant to be used with the Legacy Animation system, however it might work;

all we’re really doing is just Keyframing sounds when your foot touches the ground.

If you open the Animation window (Ctrl+6) your animations will likely be read-only.

I read online, a long time ago, if you do some sort of copy-paste magic, the animations will no longer be read-only.

Then, you would be able to add a keyframe, and call the function/method “FootstepLeft” and “FootstepRight” when your feet touch the ground.


(DarkDeivel) #29

You really helped me! Specify call functions from a script, you can even if the animation is read-only!

P.S. If you want to still edit the animation, you just need to find a clip in fbx object and press Ctrl + D.


(Sergey Ryabchenko) #30

Could you send your footstep particle FX, please :slight_smile: ?


(Marshall Heffernan) #31

I cannot; I bought them off of the Unity Asset Store.

There are, however, many free Particle Systems on the Asset Store.

If you’re interested in making your own, or learning how to do so, check out
Tyler Wissler on Youtube, or
Mirza Beig on Youtube!


(Helgard de Barros) #32

Hi @itsmars

I have a funny problem. Been trying for two days and can’t find a cause or a way around it.

I have two cameras on my player, the normal third person camera, and the second a camera just in front of the player.

40

Then I have this to switch between the two cameras.

39

So, when my player starts talking to an NPC, it switches to a close up view of the person he is talking to.

When he stops the interaction, it switches back to the third person camera.

Everything is working fine, except that when I stop the interaction, and switch back to the third person camera, it plays the water footstep sound. Previously when I tried this, it was playing a different footstep sound.

I can’t seem to figure out why the sound plays, or how to stop it. I can’t move the audio source for either the footsteps or Unistorm (I thought it might be a conflict with Unistorm, which uses the same audio source).

Any ideas why the sound plays? Any ideas of how to solve this?


(Helgard de Barros) #33

If I could adjust the zoom distance without switching cameras, it would solve this problem, but I couldn’t get this to work:

31


(Helgard de Barros) #34

Ok, so for now, this is what I have got. The camera zooms in and looks at the NPC, the only problem is that you actually have to turn the scroll wheel to activate this. When you stop talking to the NPC, you have to turn the scroll wheel to get your camera back to it’s proper settings, so this is not the ideal solution.


(Helgard de Barros) #35

OK, I found the problem. It was AQUAS causing the problem. It was not the footsteps water sound but the splash sound from AQUAS, which sounds the same.

Still don’t know why it plays the sound but I found a workaround.