Full of errors in Unity 5.6.5


#1

I cannot even start to use this tool, since whatever I do it throws an error.

For example Window->TileEd->Settings causes these errors:
1.
TypeLoadException: Could not load type ‘UnityEngine.ImageConversion’ from assembly ‘plyLibEditor’.
TileEd.TileEd_Settings.OnEnable () (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEd_Settings.cs:80)
UnityEditor.EditorWindow:GetWindow(String)
TileEd.TileEd_Settings:Show_Window() (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEd_Settings.cs:69)
TileEd.TileEdGlobal:Show_Settings() (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEdGlobal.cs:149)

TypeLoadException: Could not load type ‘UnityEngine.ImageConversion’ from assembly ‘plyLibEditor’.
TileEd.TileEd_Settings.Show_Window () (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEd_Settings.cs:70)
TileEd.TileEdGlobal.Show_Settings () (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEdGlobal.cs:149)

TypeLoadException: Could not load type ‘UnityEngine.ImageConversion’ from assembly ‘plyLibEditor’.
plyLibEditor.plyEdGUI+StyleDefs…ctor () (at D:/DevUnity/_SOURCE/plyLib/plyLibEditor/plyEdGUI.cs:133)
plyLibEditor.plyEdGUI.get_Styles () (at D:/DevUnity/_SOURCE/plyLib/plyLibEditor/plyEdGUI.cs:275)
plyLibEditor.plyEdGUI.Tabbar (System.Int32& selected, UnityEngine.GUIContent[] labels) (at D:/DevUnity/_SOURCE/plyLib/plyLibEditor/plyEdGUI.cs:1562)
TileEd.TileEd_Settings.OnGUI () (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEd_Settings.cs:119)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

Even Window->TileEd->About causes an error:
TypeLoadException: Could not load type ‘UnityEngine.ImageConversion’ from assembly ‘plyLibEditor’.
TileEd.TileEdGlobal.Show_About () (at D:/DevUnity/_SOURCE/TileEd/TileEd2/TileEdGlobal.cs:163)

Please provide way to fix and/or updated version.
I just purchased this and I do not feel happy with this, starting using my purchase by wasting time on this!!!


(Leslie Young) #2

You will note on Asset Store that lowest supported version by TileEd is Unity 2017.1. I recommend you start on latest Unity if this is a new project.