Input Settings Re: Input Axis plyPad1A# [Solved]!


(Levi Fraser) #1

Hello!

In the process of making my game I used a third party character controller to get around since I had not baked a navmesh to the scene. (The terrain is 8k2) Now that I’ve got all of the structures for the city I’m working on in place I’ve baked a navmesh and am switching back to the plyGame character controller setup, except I’ve run into an issue that I’m not quite sure how to deal with as I have no experience in input settings yet.

Error reads as follows:
ArgumentException: Input Axis plyPad1A# is not setup.
To change the input settings use: Edit -> Project Settings -> Input.

Where “#” is 1-10.

Now I’ve pulled up the input settings and my understanding from reading through the forum is that plyGame is supposed to have added these. I am however, not sure how to add them manually and if there is perhaps an easier way to rebuild that data through plyGames interface?

Any help would be very much so appreciated.

Very Respectfully,
Levi Fraser


(Levi Fraser) #2

For anyone also using Invector:

The Invector add-on over-writes Tags, Input, Layers on import. There is an option to Un-Check this. As for putting the input settings back in. It was simple matter of opening up another project and checking the input settings that plyGame generated. Inputing manually was quite easy and took only 5 minutes or so to fix. Instead of overwriting Invectors input settings, I just upped the Size from 31 to 44 and added in the 13 plyPad settings.

o7
Levi


(Leslie Young) #3

Just a note on the NavMesh; you do not need it if you are not using a character controller that needs it.
Only the plyGame/Character/Player/Top-Down Nav Controller
and plyGame/Character/NPC/Movement/Pro-Move (navmesh) needs it.


(Fredrik Olsson) #4

I have This problem and i dont have any third-party , just plygame and unity.
opened a clean project in the newest updates.
would like to know all the settings, since just adding “plyPad1A1” did not work
and walking forward or backward does not work.
scrolling does not work either.
and do not have an another project to get the settings from.

After rebboting, and adding another 00bootsrtap in the build.
i could add them manually. so nvm.


(Leslie Young) #5

Documentation can be found here https://plyoung.github.io/plygame.html
and tutorial videos here https://www.youtube.com/playlist?list=PLuaBtUXEKcdJCbNoDg0tJ9TUdkNRDrKlI

If you are just starting out with plyGame I suggest you go through these.
For the input system you need to run the Setup Input Manager to make sure the correct axis are defined in Unity https://plyoung.github.io/plygame-input-settings.html

After rebboting, and adding another 00bootsrtap in the build.

Not sure what you mean by this. There should be only one bootstrap scene in the project and in the build settings and it should always be the 1st scene in the list. plyGame should take care of this for you after being installed into a new project. If something gets messed up you can use the tools > plyoung > lyGame > refresh & update menu option to try resolve it.


(Fredrik Olsson) #6

If you are just starting out with plyGame I suggest you go through these

Na been using it long time. just came back to it after untouched for 2 years.

After rebboting, and adding another 00bootsrtap in the build.
Not sure what you mean by this

when i updated, it did not have a 00Bootrap build in to the scene. (and yes i did the tools > plyoung > plyGame > refresh & update )
so i searched one in my project and there were 2 of them in the project folders.
i took the wrong one. so

add another one

i actually ment Replacing, my bad.


(Leslie Young) #7

Yes, there are two. The one in Assets\plyoung\plyGame\System\ is a template that plyGame uses when you install the package.

The one you want in your build settings is in Assets\plyData\System\. You should never link to or edit assets in the plyoung/ folder.