Lighting becomes wonky when Combining meshes


Hi. I’m new to TileEd, and when it comes to level design I have a lot to learn with Unity. That being said, I’m unsure if I’m committing a noob mistake of some kind, or this is actually a bug.

Whenever I use the combine tool, I end up with messed up lighting. It looks as if the light is radiating out in a cube rather than a sphere. I’m loading some images to show the issue.

This image is after the mesh combine tool was used. With the two lights on the bottom you can clearly make out how it is just a cube of light. On the top level, it is harder to see, but along the walls you can make out a clear cut line of light. Yet, the same exact level before the combine tool is used looks like…

It’s like the lights just stop blending. Am I doing something wrong? How do I fix this?

(Marshall Heffernan) #2

This is how Unity lighting works.

Go to Edit > Project Settings > Quality

and change your “Pixel Light Count” to a higher number.

Beware, increasing this too high will drastically reduce performance.

An easy fix would be to light your scene through mostly Ambient lighting, and then use a few point lights here and there (as opposed to using just point lights for the entire scene, as it looks like you might be doing).


So it was me being a noob! Normally I just look up whatever problem I’m having and I’m able to find an answer, but this time I couldn’t even figure out what to look up and I was making the assumption that combining meshes was the leading cause of the problem.

Thank you so much for your answer and your suggestion on the lighting. This was extremely helpful!

(Leslie Young) #4

Thanks for the tip Marshall. I’m not too clued up on lighting scenes yet myself.
Alchemy, do you have “generate uv2” enabled in the TileEd settings? You will probably need this.


Yes! I did enable it. I agree. I’m definitely going to need it for what I’m trying to do.