My game is almost finished, but three bugs remain: Bug number 5 - solved


(Helgard de Barros) #1

When I start a game, the game starts fine.

19

If I exit the game, and then start again, and load a saved game, the game starts fine.

20

But if I am in the game, and I save a game, and then go to the main menu, and load a saved game, then the player controls don’t work. I can’t move, jump, perform attacks, etc. But if I open a PlyRPG menu screen, and close it, then I get control of the player back.

I have tried on Loadgame to tell it to open and close the MainMenu screen after the load game, but that didn’t fix it.

So any ideas what I can do to stop this happening?


(Francois) #2

I had something similar recently, I had to press escape twice in order to return to the game (like it was paused). Turned out that my game menu did not “disable” as expected. Maybe try hiding the called menu?


(Helgard de Barros) #3

Not sure what I can hide. When it goes back into the game it is on this screen, the player is doing his idle animation, and all the NPC’s, etc, are moving, so the game is not frozen or paused, just the controls for the player don’t work. So if I click the gear icon on the bottom right.

28am(1920x1080)Capture

Then I click “Return to game”, then everything works fine.

37am(1920x1080)Capture

So I need to do some sort of refresh or something. Tried loads of different things so far but nothing is working.


(Leslie Young) #4

That is strange. I almost thought the game’s global pause flag might be enabled but then the NPCs would not be moving.


(Helgard de Barros) #5

@leslie on closer inspection, I see that the NPC’s are not moving. Their idle animations are playing, which made me think that they were moving, but those that are set to wander just stand in one place and their idle animation plays. So maybe the game’s global pause is enabled?


(Leslie Young) #6

Use the UnPause Block just before you start the load. The UI set game to paused state and then you started the loading which removes the UI and does pausing never gets released.