plyGame Version 2.3.7

(Leslie Young) #1

plyGame 2.3.7

  • Updated to include RPG 1.2.0, Blox 1.3.5, DiaQ 2.1.1

plyRPG 1.2.0

  • Updated: The Item Bag now has option to prevent multiple stacks of the same item
  • Updated: Item Bag can auto sort to fill prior slots when Items added or Removed. Should only be used in bags where items do not span multiple slots
  • Updated: Changed defaults of cursor locks on player and camera controllers to false
  • Fixed: Error in Actor when trying to restore Skills after scene change
  • Fixed: Skill Block was forcing caching of the Skill when a string name was used; rather the other way around when you chose the Skill from a list
  • Fixed: NPC was not disengaging dead target

plyBlox 1.3.5

  • Updated: RaiuLyn’s OnClickTriggerBloxEvent component
  • Updated: Random Int Block can now be set to be max inclusive
  • Updated: The Random Sphere and Circle Blocks now takes an optional radius value

DiaQ 2.1.1

  • Updated: Text wrapping for Dialogue Node field in inspector

plyGame 2.3.9
(Luka Andric) #2

I have just updated but still says the same version not the new

(Leslie Young) #3

I probably forgot to update the version number at the top of the version files.
Just check the version.txt. If it shows entries for the updates then you are good.

(Luka Andric) #4

And text says the same :confused:

(Michael Urvan) #5

Maybe you updated but did not import? It’s possible to update (download) new version but not import it. Find PlyGame in your asset store downloads and click Import.

(Luka Andric) #6

Can u tell me how to do other way then that :confused: because i did that

(Leslie Young) #7

Just checked and the version info is correct so your update is failing.

The version file in \Assets\plyoung\plyGame\Documentation\version.txt should look like this. If it does not then try the things I mention in this post.

version: 2.3.7
© Leslie Young

Note: 	plyCommon, plyBlox, plyRPG, and DiaQ version notes
		will be in their respective folders


Version 2.3.7

- Updated to include RPG 1.2.0, Blox 1.3.5, DiaQ 2.1.1

Version 2.3.6

- Updated to plyRPG 1.1.9, plyBlox 1.3.4, and DiaQ 2.1.0

(Luka Andric) #8

Will check again

(Leslie Young) #9



  • Fixed: Items being picked/ dropped will restore the active blox state too
  • Fixed: Error in loot tables


  • Fixed: Added option to suppress error message when condition key not found

(Luka Andric) #10

I get errors after import

Assets/plyoung/DiaQ/Sample/DiaQSample.cs(166,39): error CS1501: No overload for method `ConditionPerformed' takes `1' arguments

Assets/plyoung/DiaQ/Sample/DiaQSample.cs(172,39): error CS1501: No overload for method `ConditionPerformed' takes `1' arguments

(Leslie Young) #11

Thanks… I forgot to update the sample script.

Btw. .the DiaQ Sample should not be installed in a plyGame project. Delete the Assets/plyoung/DiaQ/Sample/ folder if this is a plyGame project.

(Leslie Young) #12


  • Only updated the DiaQ sample. No need to get this update if you are not using the sample script (not applicable in plyGame).


  • Updated: The camera controller was setting Camera reference null when destroyed but this could mess things up if the camera was changed just before destroying the player


  • Updated: Added basic support for moving platforms to top-down and 3rd person player controllers. See PF_Support option in Inspector. Note that jumping does not work well when it is enabled