'Recreate' clear object properties ;(

(Sergej Voronov) #1

I have many Props with custom scripts , after placing object i set some values manually.
When i press ‘recreate’ all my properties disappear! can its be fixed? We dont need ‘recreate’ props! only tiles!

(Leslie Young) #2

No. When you use “recreate” all placed objects are removed from the scene and new ones added from the prefabs. So you see the values/ defaults from your prefabs.

I’ll see if I can separate out what gets recreated so you can select to not touch the props.

(Sergej Voronov) #3

tnx! maybe just create two buttons? ‘recreate tiles’ and ‘recreate props’?
Its very important , at this moment impossible to use interactive game objects in TileEd

(Leslie Young) #4

I’ve added an option in the TileEd settings.
You on Unity 5.5 though? The build I submitted was created with it.

(Sergej Voronov) #5

5.4 , i need upgrade to 5.5 for new feature?

(Sergej Voronov) #6

I set checkbox 'recreate ignores Props’
When i tap Recreate , TileEd delete all props from map! ;(

(Sergej Voronov) #7

P.S. Just suggestion :wink: Show default object inspector when Prop selected by ctrl+click

(Leslie Young) #8

I’ll have a look… might have messed up something while adding the feature… :unamused:

(Leslie Young) #9

Found problem. Watch for update 1.2.5.

I’ve also made a change to how the selection wire is disabled. I no longer apply it to the tile/ prop objects but are using the new Gizmo options to hide the outline when TileEd is on and enable again when TileEd no longer active.

I will not be able to add the Ctrl+Click option since that is used for selection in TileEd but you can simply click away form the map (in hierarchy for example) and will then be able to click on Props in scene to select and see their inspectors again. They should also show the outline now since the changes made. If they do not just select TileEd GameObject and go menu: GameObject > Show Wireframe to reset the changes the old TileEd version made to the objects.

(Sergej Voronov) #10

Tnx you very much! All works fine now!