Sapacebar acting up


(Allan Nielsen) #1

Hi there.

I am using Vinoma for a an adult oriented VN and it works like a charm. Speaking as a true non-coder, you have made it possible for me, to begin development of many a story, that I have written and who have, so far, only found life on paper or on harddrives.
Thank you for that! Your work is amazing!

I have run into a problem, though, and I hope that you will be able to help me (or anyone really):
I have set up the WAIT effect to “any button”.
When I use spacebar and get to a choice (signified by a two or more buttons), and I accidentally press the spacebar one time too many, the first choice (button) is automatically chosen for me, and the story advances down that branch.
Is there any way to stop this from happening?

Also, is it somehow possible to make a “skip already seen text” button?

I hope that you, or any other on these forums, will be able to help me out with this problem of mine.
Once again, a great product!

Cheers - Allan


(Leslie Young) #2

The button probably gets focus and Spacebar is handled like Enter. You can turn that off though. Check in the input settings; Menu: Edit > Project Settings > Input. Look for “submit” entry in Inspector. There should be two, one of them has “space” as an entry. Just delete the word and keep the input field empty.


(Allan Nielsen) #3

HAH!
That worked.

Thank you.

Cheers - Allan