There is a display problem in the BloxEd

(nantianliao) #1

My Block is a bit long, It is located a little far from the beginning of the editor. you can try it.
Unity Ver : 5.6
Blox Ver : 3.4.0

Small issue blox3 update
(Leslie Young) #2

No sure how to replicate the problem. I tried with lots of Blocks in each other and with very long variable names but they still render to the end. (I zoomed out in the screenshot only to show what kind of depth I tested at)

Send me an export of the Assets/projectData/Blox/defs/ folder and I will try to import that to see the problem. (remember to deselect dependencies in the export window else a lot files from your project might be included)

(nantianliao) #3

test.unitypackage (3.3 KB)

(Leslie Young) #4

oh, it is a Block outside of the Event hierarchy. Yes, those have a cut-off value for the width of the Blocks since 1st calculating what the true width must be would make the Blocks editor slower to render.

I’ll look into either increasing this value or adding an option to calculate the true width.

[edit] Fixed in 3.4.1

(nantianliao) #5

Thank you very much ! haha