There is a problem displaying the component icons in MacOS

(nantianliao) #1


(nantianliao) #2

Nothing was deleted from the new project. @leslie

(Leslie Young) #3

Is the Gizmos folder present in the project? That is where Unity looks for these icons.

(nantianliao) #4

No, they don’t seem to be imported.

(William Ianneci) #5

Have you tried re importing PlyGame from the asset store?

(nantianliao) #6

PlyGame? Sorry, I don’t have this asset. I only have Blox3’s license. I tried to re import Blox3, but it was the same result.

(William Ianneci) #7

HA, never mind, I didn’t realize you were referring to Blox3, ha. Time more Coffee. But same question, did you try to re-import Blox3 from the asset store to get the missing files.

(nantianliao) #8

I have re-imported unitypackage from Asset Store, but there is still no icon Folder after import. Thank you for your advice, anyway.

(Leslie Young) #9

I’ve just created a new project and imported Blox from the asset store and it came in fine and created the Gizmos folder. But I am on Windows.

Do you get any messages (like errors) in the console? Make sure you did not turn them off (buttons to the right on console toolbar).

(nantianliao) #10

Sorry,There is no messages in the console. I promise I didn’t do anything until the import was complete. I found the same problem in the previous blox’s version. Of course, I tested it under the Windows system, and in Unity it didn’t have that problem, I don’t know why this happens at MacOS.

(Leslie Young) #11

MacOS and Windows handling of paths differ. Probably something stupid on my part and you are only the 1st to report this problem. I do not work on OSX so I would have never seen the problem.

For now you can manually extract the icons to the Gizmos folder (like I show in screenshot). They are located in Assets\plyoung\Blox\packages\

(nantianliao) #12

Thank You!