Unity update problem


(Helgard de Barros) #1

I updated Unity from 2017.4.1f1 to 2017.4.2f2, and now my character controller isn’t working properly.

The buttons work to move the player, but the animations are not working, he stays in his idle animations, and doesn’t switch to walk, run, etc.

The attack animations still work, but the animations triggered by the character controller do not.

I have tried to Refresh and Update build settings, etc, but can’t get it to work. There are no error messages.

Any advice on what to do, except going back to the earlier version? I can’t update to 2018 yet because some of my plug-ins don’t work with 2018 yet.


(Leslie Young) #2

No idea what could cause this if you do not get warnings or errors to help identify problems. There was hardly anything to change, code side, for the Unity 2018 update so I doubt there can be that big a change between 4.1f1 and f2.


(Francois) #3

Hey Helgard!

Honestly, I do not think that this is a plyGame issue. I literally sat with a similar issue 2 days ago. I went from 2017.4.2f2 to 2018.1 beta and had the exact same issue. THEN I download 2018.1 full release and upgraded from 2017.4.2f2 to that and finally the project worked as expected.

Go ahead and try upgrading from 2017.4.2f2 to 2018.1 release. Remember to back up? :slight_smile:


(Francois) #4

Oops sorry, I missed this part.


(Helgard de Barros) #5

I tried to update to 2018, but I am using 5 other plugins besides Plygame, and two of those aren’t compatible with 2018 yet, so the game doesn’t run, just throws up loads of errors. I will go back to the earlier release for now.

Very frustrating when there are no error messages and nothing in the release notes suggests that this would happen.


(Helgard de Barros) #6

So, I uninstalled 2017.4.2f2, and installed 2017.4.1f1, and opened my back-up I made in 2017.4.1f1 (which was working perfectly when I made the back-up).

The problem persists. So it has nothing to do with the update. The last thing I did before making the back-up was this:

Untitled

This was working before the back-up was made and when I saved the project.

I tried de-activating those blocks but it made no difference. Still no errors, so I have no idea what to check or where to start with finding the error.


(Helgard de Barros) #7

I am going to try an earlier back-up and see if the problem appears there as well.


(Francois) #8

Ah dude good luck! I think we all know the feeling of having to deal with issues in Unity. :slight_smile:


(Helgard de Barros) #9

So, after spending the whole day trying various things, this is the situation.

I open an earlier back-up in 2017.4.1f1 and it works fine. I update to 2017.4.2f2 and it works fine. I save and close Unity, open it again and it works fine.

If I open an earlier back-up in 2017.4.1f1 and add the above blocks it works fine. I save and close Unity, open it again and it works fine.

If I update that to 2017.4.2f2 it works fine, until I save and close Unity, and open it again. Then the animations triggered by the Third Person Controller, the walk, run, strafe, etc, do not work.

So I can either update and not add those blocks, and everything works, or I can add those blocks and then I can’t update…


(Leslie Young) #10

Very strange since those Blocks simply uses reflection to set a property value. and it is a property in plyGame, which would not change between Unity versions.


(Helgard de Barros) #11

Leslie, I can’t understand it either. Nothing in the update should have any effect on this. I have tried to add the blocks before the update, and after the update, and both times they work perfectly fine, then I shut down Unity, open it again, and then the animations don’t work. No idea why this would happen, or what could cause it. So I am going to leave out those blocks for now and worry about it once I update to 2018, maybe it will disappear on it’s own, as many of my other problems have done. :slight_smile: