Update 3.3.3 error (Closed)


(Alien) #1

getting an error updating to 3.3.3. duplicate GUID. all blox containers are missing.

i was at blox 3.3.2 and latest 5.5 unity build.

i will get specific error after i restore the project and try again.


Blox 3 updates
(Alien) #2

Tried on 2 different projects. both go broken.


(Leslie Young) #3

I would like to take a moment and scream, … :sob:

For now, try this.

Create a new project and import new Blox into it.
Now copy (via OS file explorer) the DLLs to your existing project.

Problem will probably come up again next time you want to update Blox though so we need to figure out what is going on. I’ll PM you.


(Leslie Young) #4

I assume you followed these steps? Blox 3 updates
Note that the initial info was wrong and I updated that post a while ago. So if you moved the DLLs outside of Unity then you followed wrong instructions.


(Alien) #5

the project i emailed, the larger one, which i had followed the most recent instructions worked fine.

The 2 projects that i had followed the original instructions do not work on the upgrade. hope this helps.

jade


(Alien) #6

I tried this on one of the projects that is still having issues with. (the hexexport project i sent via PM). it didn’t work. i only moved the DLLs and this is the error i get when running unity.

Since that didn’t work, i just tried to copy all the files over under assembly/Editor and assembly/runtime. that didn’t work either, gets me back to missing all the blox containers on all the objects.


(Leslie Young) #7

I think I’ve identified the problem and will be creating a new patch soon.

I am submitting 3.3.4. It will have the correct meta files.Please check the update notes for 3.3.4 and follow the upgrade process exactly like that from your project backups. It will not work to follow it for a project that is already broken.(well, maybe since the old GUIDs will be restored and could fix your missing Blox definitions problem)


(Alien) #8

Hey Leslie,

I don’t have a pre 3.3.0 backup at this point for the project that is having problems. i tried to run the process you outlined for 3.3.4 but still having the same errors and missing scripts. the hexproject I’m having problems with, was updated with the older / incorrect process. given i don’t have a pre 3.3.0 backup, I’m just going to call that project broken and recreate it. it was only a few days work and i should be able to take screenshots and rebuild it fairly quickly. it’s for a tutorial i was creating for blox3, so redoing it again, so i can record it was in order anyway.
I’ve been able to update my main project, which i had followed the newer instructions and everything went fine. That was probably the more important project…

let me know if you still want a copy of the plyoung directory or anything. but at this point i don’t want you to have to waste anymore time on it, if I’m the only one having a problem.


(Leslie Young) #9

The only way to recover in such a case would be to install latest Blox so that you have the correct meta files and GUIDs and then manually attach the scripts to the assets which are now showing “missing script” in their inspectors.

That is the reason Blox Definitions “disappeared”. The asset files in Assets\projectData\Blox\defs\ are most likely showing the missing script errors.

They will not be the only ones though so it will be easier to just start over if you can.

This problem should not occur again. I’ve now learned how to deal with Unity’s use of the meta files and GUIDs and will be more careful with them in future updates.


(Alien) #10

yes, that’s what i did. thanks