When Reporting Errors


(Leslie Young) #1

How to report Problems and post Console Messages.

When relevant please include some basic info like which version of the asset, what version of Unity (also if on OSX or Windows), and what target you are trying to build for (Windows, OSX, iSO, Android, Webplayer, etc).

When reporting an error and you have an actual error message in the Unity console please paste that error in your post. It is not always possible to guess the problem without this info.

Open the console from menu: Window > Console. Near the bottom of Window menu.

Click on the red error message and the bottom panel of the console will show more info. This info needs to be selected and copied to be pasted into your post. You can click-drag the mouse to select the text and right-click > copy.

Always look at the very 1st error shown in the console when trying to figure out why things are not working. Errors in what seems to be unrelated areas can lead to other errors. So always start at the top and work through the errors.

When Unity Crash

If Unity crashes you can still access the log to find what is happening.

  1. Open the Console and then the Log file as shown in picture below. (The log will open in a text editor)
  2. Clear everything in the Log and save it. Do not close the text editor since you will need to look at the file again shortly.
  3. Now do what you need to do to make Unity crash.
  4. Switch back to the text editor and if it asks to re-load the file, choose Yes.
  5. Check what log has to say.

Under Windows the log is at %LOCALAPPDATA%\Unity\Editor\Editor.log


[PlayEditor] Not working
NullReferenceException Bug
Generating a grid programmatically
Game Crashing 2.5.0b
Does plyGame works on mobile?
Can't select animation in Legacy Anim Control
No contact with the NPCs
No Video option in screens menu
Errors with Unity 2017.3.0b11
On click trigger blox event script error (resolved it self with plygame update)
Cannot get a WebGL build to Work Properly
Error in unity 5.3.2f1 with DiaQEngine
Re-sizing screen to properly fit mobile device
HELP! NullReferenceException
Help with something
Need some help With Lvl
Problem with Log
Need some help with Quests on Changing Scene
Error Question (Solved)
Equipment
Setting the Y coordinate of an object to another's
Problem when import pakage
About script
Re-sizing screen to properly fit mobile device
The type or namespace name `plyRPG' could not be found
Set Text not working (Load/Save Tutorial)
Why am I getting this error?
I have a problem
Ply RPG_UI disabled while game mode
3rd party camera
Storing player name
Projectile Scripts Errors
Upgrade to U2K17 and PlyGame Errors
Set Cursor Image problem
HELP! Buttons doesn't work anymore
No Scene Being Displayed
Character enter the scene again
ANNOYING error
Marker question
Help to Build
[Question] The Block Type Could Not Be Found
RPG_UI - how to edit the stuff around here?
No Targets with Custom Character Controller
I can't move the character... I need help
Error Code on Import & Fresh Project
(Leslie Young) #3

Clean up the Cache

When it seems like your version of a Unity package is not updating properly then try these steps.

  1. In the package manager, click on Download (or Update) again and wait for it to finish before pressing Import.

  1. If that did not seem to work then go to where Unity stores the packages and delete it. You can delete all content of the PLYoung folder.

First close Unity, then delete the package(s). After that you can restart Unity and let it download the package(s) again.

Unity 5
Windows: %APPDATA%\Unity\Asset Store-5.x\PL Young
OSX: ~/Library/Unity/Asset\ Store-5.x/PL\ Young/

Unity 4
Windows: %APPDATA%\Unity\Asset Store\PL Young
OSX: ~/Library/Unity/Asset\ Store/PL\ Young/

These folders might be hidden.


Error with unity 5.1.2f1
Error Code on Import & Fresh Project
MissingMethodException and NotSupportedException Errors
Error Code on Import & Fresh Project
Game Crashing 2.5.0b
Problem in Unity 5.1.1f1 (64-bit)
Gray screen after build
NullReferenceException
Blox 3 settings reset after play
Begin graph doesn't work (mobile) (Fixed)
Prefab problem after update? (Solved)
No Slots In Inventory
No Grid after 1.0.7 update
Skill wont activate (RESOLVED)
(Answered) Receiving Error Message, probably for a good reason though
[Bug] Font could not be loaded
(Leslie Young) #8

(Leslie Young) #9